Just like the Daylite app itself, the iOSXpert PluginCenter and the plugins require macOS 10.15 or higher. If you are still using macOS 10.13 High Sierra or macOS 10.14 Mojave you need to update your macOS to 10.15 or higher to get the latest version of PluginCenter and the plugins. Our website features an overview of the compatible macOS versions.
If you cannot update your Mac, you can continue to use the old versions of PluginCenter and the plugins installed previously on that computer. Please keep in mind that you won't receive further updates for Daylite and the plugins for this computer setup in the future.
The most important reason to update to macOS 10.15 or higher is that macOS 10.13 will not receive security updates from Apple in future either
This website lets you check the compatibility of your Mac with macOS 10.15 and helps you with the update process.