Just like the Daylite app itself, the iOSXpert PluginCenter (from version 1.9 onwards) requires macOS 10.12 or higher. If you are still using macOS 10.10 Yosemite or macOS 10.11 El Capitan you need to update your macOS to 10.12 or higher to get the latest version of PluginCenter and the plugins. Our website features an overview of the compatible macOS versions.
If you cannot update your Mac, you can continue to use the old versions of PluginCenter and the plugins already installed previously on that computer. Please keep in mind that you won't receive further updates for Daylite and the plugins for this computer setup in the future.
The most important reason to update to macOS 10.12 or higher is that macOS 10.10 and 10.11 haven't received security relevant updates for years.
This website lets you test the compatibility of your Mac with macOS 10.12 and helps you with the update process.